The Jupiter X WordPress theme is compatible with most of the plugins since it follows standard coding practices.


We officially support the following plugins, so if our theme is causing compatibility issues, we will address them as soon as possible. 


WPML - version 3.7.1.
BuddyPress - version 2.8.2.
bbPress - version 2.5.13
Loco Translate - version 2.0.14.
PolyLang - version 2.1.6.
WooCommerce Product Table - version 2.1.4.
UberMenu - version 3.4.1.1.


Bundled Plugins

Bundled plugins are those that are included in the Jupiter X theme for free. We have acquired the appropriate licenses for these plugins. The list of the bundled plugins is provided in this article.


Community Plugins

We have not tested the following plugins officially but our clients are using them without problems:

Use Any Font - version 4.7.3.
The Events Calendar - version 4.5.8.

Note: Please make sure the plugin server requirements are provided on your web host first. You can check the Jupiter X server requirements here. Also, read this article to understand why you should keep your active plugins at minimum. 

Did this answer your question?